Saltar al contenido

Corregir el error “Dependencia de xbmc.python”

El mensaje de error “No se pudo resolver la dependencia de xbmc.python” Por lo general, aparece cuando desea instalar o actualizar un addon de Kodi. En este artículo, le explicaremos qué significa el mensaje de error y cómo solucionar el problema.

Tabla de contenido

¿Qué es Python en Kodi?

Python es el lenguaje de programación utilizado por las extensiones de Kodi. Todos los addons de Kodi están escritos y desarrollados en Python. Es por eso que una versión de Python está instalada permanentemente en cada versión del centro de medios.

Dado que Python es inherente a cada instalación de Kodi, los addons de Kodi integran el lenguaje de programación de forma predeterminada. Esto permite a los desarrolladores utilizar ciertos módulos y funciones sin tener que importar todo el lenguaje de programación.

Todos los addons de Kodi utilizan Python, lo que convierte a este lenguaje de programación en una de las dependencias más importantes de Kodi.

¿Qué significa el mensaje de error “No se pudo resolver la dependencia de xbmc.python”?

Como se mencionó anteriormente, todos los addons de Kodi deben usar el lenguaje de programación Python. Es por eso que esta dependencia se almacena permanentemente en el código fuente de cada extensión.

Python se actualiza y publica regularmente en nuevas versiones. Los desarrolladores de Kodi incluyen una nueva versión de este lenguaje de programación en cada actualización del centro de medios. Entonces, si instala una nueva versión de Kodi, también tiene la versión actual de Python en su sistema.

Si los addons de Kodi están usando una versión anterior de Python, esto no es un problema. La versión requerida simplemente se instala para que la extensión correspondiente funcione correctamente.

El mensaje de error mencionado “No se pudo resolver la dependencia de xbmc.python” aparece, sin embargo, si ocurre el siguiente caso:

La versión de Python requerida de un addon de Kodi es más nueva que la de su instalación de Kodi.

Si este es el caso, aparece el mensaje de error. El error generalmente tiene un número de versión en el nombre. A continuación, el mensaje completo dice: “No se pudo resolver la dependencia de xbmc.python en la versión 2.7.13”.

Corregir el error “Dependencia de xbmc.python”

La solución a este problema es simplemente esta: ¡Instale o actualice la última versión de Kodi!

El problema es que la versión Python de Kodi no se puede actualizar con un addon de Kodi. Solo se admite la compatibilidad con versiones anteriores. Pero tan pronto como un addon de Kodi se base en una nueva versión de Media Center en el código fuente, debe actualizar su instalación de Kodi.

Recientemente, este error se ha producido con más frecuencia, ya que los desarrolladores de Kodi Addons han puesto sus extensiones en Versión Kodi 19 Matrix han cambiado.

En nuestro sitio web le explicamos paso a paso cómo Kodi en Amazon Fire TV o en PC con Windows Instalado.

Error “No se pudo resolver la dependencia de xbmc.python en la versión 3.0.0”

Si aparece el mensaje de error con un addon de Kodi “No se pudo resolver la dependencia de xbmc.python en la versión 3.0.0”, está utilizando una extensión de Kodi 18 Leia que en realidad se desarrolló para Kodi 19 Matrix.

los última versión de Kodi Como es bien sabido, se basa en el lenguaje de programación Python 3, mientras que Kodi 18 y 17 usan Python 2.

Recomendamos a todos los usuarios que se cambien a Kodi 19 Matrix. Todos los addons conocidos ahora se han actualizado y se ejecutan con la nueva versión sin ningún problema. También hay muchas extensiones nuevas para Kodi que solo funcionan con la versión 19. No hay razón para usar Kodi 18 Leia o incluso versiones anteriores.

.